Säkerhetsuppdatering släppt 2018-12-13. Bakåtkompatibilitet påverkas.

Natten till idag, 13 december 2018 släpptes en säkerhetsuppdatering (version 5.0.1) för WordPress. Motsvarande säkerhetsuppdatering har även gjorts som version 4.9.9 och för alla huvudversioner tillbaka till 3.7-grenen.

Webbplatser som använder standardinställningarna kommer att försöka uppdatera sig själva automatiskt under dagen. Om din webbplats av någon anledning inte uppdateras automatiskt bör du se till att uppdatera manuellt när du kommer åt.

Denna uppdatering innebär att WordPress på ett par ställen ”under huven” beter sig en aning annorlunda. Vanliga användare kan råka ut för att WordPress nu kontrollerar att innehållet i en fil man laddar upp stämmer överens med ändelsen på filnamnet.

Mer information finns att läsa i den officiella nyhetsnotisen och i den tekniska notisen för utvecklare.

Snart släpps WordPress 5.0 med ny redigerare – Några saker att tänka på innan du uppdaterar

Om allt går enligt planerna kommer uppdateringen till WordPress 5.0 att släppas torsdag den 6 december 2018 (troligtvis under kvällen eller natten mot fredagen).

Standardinställningen i WordPress är att uppdatering till ny huvudversion av WordPress (4.9, 5.0, 5.1 o.s.v.) sker först när administratören själv väljer att genomföra uppdateringen via administrationspanelen: Hem – Uppdateringar.

Förutom att WordPress 5.0 innehåller nödvändiga justeringar för att WordPress ska fungera väl med PHP 7.3 (som släpps i dagarna) handlar denna version om en enda sak:
En helt ny redigeringsmiljö, baserad på innehållsblock.

Redigeraren har utvecklats och provkörts under kodnamnet ”Gutenberg”, och nu anser utvecklarna att tiden är mogen för de stora massorna att ta klivet över till den nya redigeringsmiljön.

WordPress.com har gjort en beskrivning av blockredigeraren som du hittar på https://sv.support.wordpress.com/wordpress-redigerare/

Innan du uppdaterar till WordPress 5.0 kan det vara god idé att kontrollera om dina tillägg och ditt tema är förberedda för den nya redigeraren.

I synnerhet gäller detta om din webbplats på olika sätt modifierar den normala redigeringsmiljön, t.ex. genom att lägga till extra knappar i redigeraren och liknande.

Om så skulle vara fallet kan (och bör) du fortfarande uppdatera till version 5.0, men då kan det finnas anledning att installera tillägget Classic Editor för att fortsätta med den klassiska redigeraren tills dina tillägg, ditt tema (och du själv) är ikapp.

Du kan provköra Gutenberg här: https://sv.wordpress.org/gutenberg/