Support » Allmänna frågor » Äldre intregrerade WP-bloggar har slutat fungera.

  • Hej.

    Ny här och tänkte höra om någon kan tipsa om hur vi får våra äldre WP-versioner (3.0.4) att fungera igen. Det handlar om två bloggar som är integrerade i en webbsida. Båda slutade att fungera samtidigt så det handlar väl om att dom har blivit för gamla helt enkelt?

    Vi vill dock ha dessa versioner kvar då vi gillar gränssnitt och den enkla funktionen, samt att det finns en hel del äldre krönikor sparade.

    Sidan jag behöver hjälp med: [logga in för att se länken]

Visar 1 svar - 1 till 2 (av 2 totalt)
  • Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    WordPress-teamet skapar fortfarande säkerhetsuppdateringar för tidigare WordPress-versioner ända tillbaks till version 3.7.

    Men du använder en version som är ännu äldre. Som du kan se i https://wordpress.org/download/releases/ släpptes version 3.0.4 i slutet av 2010, så den har 10,5 år på nacken. Det gjordes faktiskt ytterligare 2 säkerhetsuppdateringar av den versionen under våren 2011.

    När en webbplats plötsligt slutar att fungera brukar det ofta handla om att webbhotellet har uppgraderat PHP, den underliggande programmiljön. Versionen du använder släpptes 3 år innan PHP 5.6 släpptes, vilket troligtvis innebär att du hittills har haft tur (eller att ni länge och väl har använt PHP-versioner med kända svagheter som utnyttjas av angripare).

    Jag rekommenderar starkt att du uppgraderar till senaste WordPress-versionen. Med hjälp av tilläggen https://wordpress.org/plugins/classic-widgets/ och https://wordpress.org/plugins/classic-editor/ kan du i viss mån återställa gränssnittet till hur det såg ut tidigare.

    För att kunna göra detta behöver du antagligen be ditt webbhotell att tillfälligt aktivera PHP 5.6, trots att versionen sedan länge är föråldrad och har en del kända svagheter.

    Se till att spara säkerhetskopior av databas och filer innan du kör igång. Och be någon kunnig person att kolla om de hittar några spår av skadlig kod.

    Trådstartare maharajahlive

    (@maharajahlive)

    Tack för svar. Nyinstallerade en något nyare version, 3.9.36.

    Nu har jag en annan fråga, hur tar jag bort textlänkarna ”Hem” och ”Lämna ett svar” från bloggsidan?

    I inställningarna för kommentarer hittar jag ingen sådan funktion.

Visar 1 svar - 1 till 2 (av 2 totalt)
  • Du måste vara inloggad för att svara på detta ämne.