Support » Allmänna frågor » Bugg i galleri?

  • Löst andhi1

    (@andhi1)


    Hej!
    I WordPress har jag upptäckt att det ganska enkelt gör att skapa ett fotogalleri i ett blogginlägg.
    Men, när en användare skapar ett sådant galleri händer följande.
    När en annan användare går in och tittar på inlägget med det galleri som skapats av annan användare, kan denne användare, när han/hon klickar på en bild i galleriet, via pilarna som visas i bifogad fil, se alla bilder i det mediabibliotek som jag som administratör har lagt in där:
    .
    Detta måste väl vara någon form av bugg, eller…?
    https://www.screencast.com/t/cWIlZFOUedrC

    MVH
    Anders Hidman

    Sidan jag behöver hjälp med: [logga in för att se länken]

Visar 1 svar - 1 till 6 (av 6 totalt)
  • Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    WordPress i grundutförande försöker inte dölja vilka filer som finns uppladdade i mediakatalogen. Vissa lösningar för webbplatskarta räknar inte bara upp alla sidor och alla inlägg, utan även alla mediafiler, så att t.o.m. Google hittar allt i en handvändning.

    Jag kan tänka mig att olika gallerier beter sig på olika sätt. Men om ett galleri skickar över besökaren till ”mediafilens” egen sida, så är det ditt tema som styr om det finns länkar till ”föregående/nästa”.

    Trådstartare andhi1

    (@andhi1)

    Tack Tor-Bjorn för din alltid så snabba och utmärkta support!

    Du har ju tidigare hjälpt mig med CSS-klipp som dolt vissa oönskade partier på min sajt.
    Jag undrar om du nu kan tillhanda hålla ett CSS-klipp som tar bort detta:
    2021-05-25_18-47-41
    Jag använder tema Amphibious

    MVH
    Anders

    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Jag kan inte göra det från en skärmdump, eftersom jag behöver högerklicka på elementet, välja ”Inspect (Q)” i Firefox och studera den underliggande HTML-koden för att utröna en lämplig CSS-selector att ge mig på, och även i samma verktyg för utvecklare i Firefox testa genom att lägga till den CSS jag tänkt mig i min lokala webbläsare för att se om länkarna försvinner.

    Trådstartare andhi1

    (@andhi1)

    OK.
    Vad behöver jag göra för att du skall kunna göra det du säger i ditt svar?
    Kan jag i ett PM ge dig admin-rättigheter?

    • Det här svaret redigerades för 6 månader sedan av andhi1.
    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Nej,
    Forumet fungerar bara som ”hjälp till självhjälp”. Vi förmedlar uttryckligen inte inloggningsuppgifter m.m. här i forumet. Du kan behöva hitta någon i din omgivning som du litar på för hjälp med saker som inte synliga direkt för utomstående besökare.

    Jag installerade temat på min testwebbplats.

    Du kan prova att lägga in följande under Extra CSS:

    #image-navigation {
        display: none;
    }
    Trådstartare andhi1

    (@andhi1)

    JAAAAA!
    Det fungerade.
    Tack så jättemycket för ditt engagemang 🙂

    Anders

Visar 1 svar - 1 till 6 (av 6 totalt)
  • Ämnet ”Bugg i galleri?” är stängt för nya svar.