Support » Allmänna frågor » Editor-menyn är inte längre klistrad

  • Menyraderna i editorn med classic inställning är inte lägre klistrad.
    När jag skrivit så mycket att man inte längre ser början av det jag skrivit försvinner också menyn. Jag måste alltså rulla upp för att exempelvis feta ett textstycke och rulla tillbaka ner för att fortsätta skriva. Det tar lång tid att skriva på det viset. Innan felet hängde menyn med när man skrollade neråt.

    Vet inte när felet exakt visade sig men det kan vara efter senaste uppdateringen. Jag fick det till att fungera en stund men efter jag sparat var felet tillbaka.

    Blockredigeraren fungerar det men jag kan inte använda den för den är oanvändbar i övrigt.

    Vad är fel och hur fixar jag det?

    • Detta ämne redigerades för 11 månader, 3 veckor sedan av workmannen.
    • Detta ämne redigerades för 11 månader, 3 veckor sedan av workmannen.
Visar 1 svar - 1 till 10 (av 10 totalt)
  • Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    För mig fungerar det fortfarande.
    Vilket tema använder du, och vilka tillägg är aktiva?
    Du skulle kunna installera https://wordpress.org/plugins/health-check/ och med dess felsökningsläge prova att redigera inlägg med alla tillägg inaktiverade och sedan aktivera ett tillägg i taget och för varje tillägg ladda om sidan med redigeraren för att se vad som får den att bete sig konstigt.

    Förresten, du skulle också kunna börja med att installera https://wordpress.org/plugins/enable-jquery-migrate-helper/ för att kolla om du händelsevis råkar sätta något ur spel på grund av anrop till föråldrade funktioner i Javascript-biblioteket jQuery.

    Trådstartare workmannen

    (@workmannen)

    Jag har testat med https://wordpress.org/plugins/enable-jquery-migrate-helper/ ingen skillnad.

    Det fungerade med alla tillägg och det tema jag har i ett par veckor tills 2020-12-10. Under den tiden har jag inte ändrat något men WordPress har uppdaterats och ”Advanced Editor Tools (previously TinyMCE Advanced)”.

    Dock, jag har alltid använt ”Classic Editor”. Jag avinstallerade den och installerade ”Enable Classic Editor” istället och avmarkerade ”Aktivera fullhöjdsredigerare och distraktionsfri funktionalitet” då fungerade det igen.

    Orsaken till att jag avmarkerade ”Aktivera fullhöjdsredigerare och distraktionsfri funktionalitet” beror på att jag tidigare testade med att avmarkera den och då fungerade det tills jag sparade det jag skrivit. Då aktiverades ”Aktivera fullhöjdsredigerare och distraktionsfri funktionalitet” igen av sig själv och felet kom tillbaka. Jag testade med flera olika sätt att avmarkera den men den aktiverades av sig själv om jag sparade, förnyade eller gick ut och sen in igen.

    Märkligt fel men jag är inte ensam om det märkte jag när jag sökte på det.

    Har jag blockredigeraren aktiverad är det inga problem med den det men hela redigeraren i övrigt är ett så stort problem att den i princip inte är användbar.

    Hej,

    jag har exakt samma problem; Menyn i den klassiska redigeraren är inte längre klistrad då jag scrollar min arbetsyat…heter det så?

    Mycket irriterande. Kom efter senaste uppdateringen.

    Min dator är ok. Jag har avinstallerat Classic Editor och lagt in den igen.
    Vidare har jag felsökt enligt moderatorns förslag ovan.

    Felet kvarstår. Enda skillanden är att menyn menyn ibland är klistrad, när jag startar WP vid första editering av befintlig post. Försöker jag med annan post är det samma fel.
    Min tanke…av alla miljoner användare av WP tror jag 98% använder ClassicEditor.

    Blockeditorn är en omöjlighet. Att man ska behöva läsa en manual på 100 sidor för att kunna använda den…

    Varför ändra något, som funkar bra ?

    Den överväldigande majoriteten av WP-användare är små bloggare som jag.
    Gör det inte svårt för oss pls !

    Jag och många med mig, om vi ska se på kommentarerna på olika fora om problemet , skulle välkomna en update, som rättar till detta misstag.

    annaputte

    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    @annaputte @workmannen
    Kanske ni båda kan jämföra vilka aktiva tillägg ni använder?
    Framför allt skulle jag kolla på tillägg som på något sätt påverkar redigeringsmiljön.
    När jag använder Classic editor och texten blir lång börjar texten att rulla, men knapparna (som är en del av den ”omgivande sidan”) ligger stilla.

    Trådstartare workmannen

    (@workmannen)

    Mina tillägg:

    Advanced Editor Tools (previously TinyMCE Advanced)

    Akismet Anti-Spam

    amr shortcode any widget

    CMP – Coming Soon & Maintenance Plugin

    Enable Classic Editor

    Hide My WP Ghost Lite

    List category posts

    Ajax Edit Comments

    Quote Comments

    Really Simple SSL

    Sassy Social Share

    Wordfence Security

    WP Search Insights

    WP Statistics

    Yoast SEO

    • Det här svaret redigerades för 11 månader, 2 veckor sedan av workmannen.
    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    @workmannen
    Finns felet kvar om du tillfälligt inaktiverar ”Advanced Editor Tools (previously TinyMCE Advanced)”

    eller ”Ajax Edit Comments”

    eller använder ”Classic Editor” i stället för ”Enable…”?

    Hej,

    här är mina tillägg:

    Advanced Editor Tools (previously TinyMCE Advanced, Akismet Anti-Spam, All In One SEO Pack, Classic Editor, Disable Gutenberg, Enable jQuery Migrate Helper,Google Website Translator, Health Check & Troubleshooting, One Click SSL,
    P3 (Plugin Performance Profiler), TinyMCE Advanced Language Pack, W3 Total Cache,

    WP Statistics

    annaputte

    Trådstartare workmannen

    (@workmannen)

    tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    för 8 timmar, 42 minuter sedan

    @workmannen
    Finns felet kvar om du tillfälligt inaktiverar ”Advanced Editor Tools (previously TinyMCE Advanced)”

    eller ”Ajax Edit Comments”

    eller använder ”Classic Editor” i stället för ”Enable…”?

    Felet finns kvar när jag avaktiverat ”Advanced Editor Tools (previously TinyMCE Advanced)”.
    Felet finns kvar när jag använder ”Classic Editor” men felet upphör delvis när jag använder ”Enable…”. Eftersom det fungerar så här har jag inte brytt mig om att avaktivera fler tillägg.
    Felet kom när WordPress uppdaterades senast och det verkar som om att något inte samarbetar med ”Classic Editor” längre. Något händer också med ”Enable Classic Editor” eftersom den bara fungerar med ”Aktivera fullhöjdsredigerare och distraktionsfri funktionalitet” avbockad.

    Ser att också @annaputte använder ”Classic Editor” som jag gjorde när det inte fungerade för mig.

    Jag kapitulerade för problemen efter sista updaten.

    Min utväg, tyvärr, var att backa tillbaka till version 5.5.3.
    Finns plugin att göra det med. Vidare blockade jag automatiska
    uppdateringar i WP via ännu ett plugin, så slapp jag editera.

    Nu fungerar allt som jag vill ! Men jag hoppas på en ny update
    som rättar till felen från senaste versionen av WP.

    annaputte

    Trådstartare workmannen

    (@workmannen)

    annaputte

    (@annaputte)

    för 2 timmar, 48 minuter sedan

    Jag kapitulerade för problemen efter sista updaten.

    Min utväg, tyvärr, var att backa tillbaka till version 5.5.3.
    Finns plugin att göra det med. Vidare blockade jag automatiska
    uppdateringar i WP via ännu ett plugin, så slapp jag editera.

    Nu fungerar allt som jag vill ! Men jag hoppas på en ny update
    som rättar till felen från senaste versionen av WP.

    annaputte

    Från början består problemet i att utvecklarna fått för sig att vi vill ha en ny editor och så skapade de missfostret Gutenberg. Jag tänker på alla som aldrig använt WordPress och testar det. De kommer genast att leta efter något annat när de ser editorn alternativt hittar de inte editorn för det är inte lätt att förstå att Gutenberg ÄR editorn eftersom det i stort sett bara är en blank sida.

Visar 1 svar - 1 till 10 (av 10 totalt)
  • Ämnet ”Editor-menyn är inte längre klistrad” är stängt för nya svar.