Support » Allmänna frågor » Fatal error efter jag försökt byta ut en gammal site mot en ny design

  • Hej!

    Jag designade om vår hemsida. Jag redigerade en kopia på en lokal server & sedan kopierade över på den nya. Jag använde mig att ett plug-in för att byta ut den nya designen mot den gamla. Mitt i denna process uppstod ett fel,
    jag kan nu inte logga in på hemsidan & får upp detta felmeddelande:

    Fatal error: Cannot redeclare acf_get_current_url() (previously declared in /home/justiceh/public_html/wp-content/plugins/advanced-custom-fields/includes/api/api-helpers.php:3267) in /home/justiceh/public_html/wp-content/plugins/advanced-custom-fields/includes/acf-helper-functions.php on line 466

    Hur fixar jag detta problem? Super tacksam för hjälp.

    Sidan jag behöver hjälp med: [logga in för att se länken]

Visar 1 svar - 1 till 3 (av 3 totalt)
  • Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Hmm.
    Bäst är nog att ställa en fråga i tilläggets eget forum https://wordpress.org/support/plugin/advanced-custom-fields/ eftersom det kan vara en logisk kullerbytta i tilläggets egen kod.

    Trådstartare eliasmalm

    (@eliasmalm)

    Tack så mycket! Jag ställer denna fråga i det forumet.

    Vill bara dubbelkolla en sak:

    Problemet uppstod när jag försökte byta ut den gamla siten mot den nya & sidan råkade uppdatera mitt i proccessen. Är det fortfarande problem med det plug-in eller kan man göra något för att gå tillbaka till den tidigare hemsidan?

    Stort tack för hjälpen!

    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Man kan ju alltid försöka att återställa en tidigare säkerhetskopia av hela webbplatsen eller rulla tillbaka till föregående version av tillägget i fråga. Men om felet introducerades med den senaste versionen är det förstås bäst om felet återställs/rättas i källan. Det är inte trevligt att ligga kvar på gamla versioner av programvara. Då finns risk att man inte heller uppdaterar bort eventuella upptäckta och åtgärdade säkerhetshål.

Visar 1 svar - 1 till 3 (av 3 totalt)
  • Du måste vara inloggad för att svara på detta ämne.