Support » Allmänna frågor » Felmeddelande vid uppladdning av bild, kan ej länka, fel vid svar på kommentar

  • Hej,
    Från en dag till en annan (utan att jag uppdaterat eller ändrat något) har jag en del småproblem. När jag försöker ladda upp en bild till ett inlägg får jag felmeddelandet ”An error occured in the upload. Please try again later.”. Det går inte heller att infoga någon bild från biblioteket för sidan bara tänker och inga bilder dyker upp. Går jag in i mediabiblioteket geom menyn ser jag dock att den nya bilden är där.
    När jag i inlägget försöker göra en länk till ett internt inlägg funkar inte det heller, den bara tänker och hittar inga inlägg.
    När jag ska svara och på en kommentar får jag också ett felmeddelande, egentligen bara en röd list. Men sen har kommentaren ändå publicerats.
    Efter jag fick mitt problem såg jag att en ny version av WordPress (6.0.3) kommit så då installerade jag den för att se om det löste problemet, men icke.
    Har temat Kale.

    Hälsningar
    Emilie

    Sidan jag behöver hjälp med: [logga in för att se länken]

Visar 1 svar - 1 till 9 (av 9 totalt)
  • Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Min gissning är att ditt webbhotell sparkat upp dig till en PHP-version som något av dina tillägg (eller möjligen temat) inte är kompatibel med ännu. En tillfällig lösning kan i så fall vara att byta ner PHP-versionen igen. Det gör du via webbhotellet, vanligtvis i deras kontrollpanel, annars via deras support.

    Trådstartare emilie87

    (@emilie87)

    Tack för ditt svar! Testade att byta till de olika PHP-versionerna som finns, men inget av det funkade tyvärr.

    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Om du aktiverar loggning av PHP-fel i WordPress (obs TILLFÄLLIGT) finns det goda chanser att få bättre ledtrådar.

    Följ instruktionerna i https://wordpress.org/support/article/debugging-in-wordpress/ och ändra i filen /wp-config.php raden (För detta behöver du antagligen FTP, som jag kommenterar nedan, och en bra textredigerare, på Windows rekommenderar jag Notepad-plus-plus.)

    define( ’WP_DEBUG’, false );
    till

    define( ’WP_DEBUG’, true );
    define( ’WP_DEBUG_LOG’, true );

    Eventuella fel kommer att skrivas till filen /wp-content/debug.log

    Kom ihåg att efteråt stänga av loggningen. Annars finns risken att loggen tar onödigt mycket plats och att eventuella angripare i framtiden via loggen kan få information om säkerhetsproblem som de kan försöka att utnyttja.

    Om du behöver hjälp med att tolka eventuella felmeddelanden kan du posta dem här. Kolla bara så att du inte av misstag lägger ut någon känslig information.

    För att kunna göra dessa ändringar behöver du använda FTP (t.ex. med FileZilla som klient) för att kunna tanka hem wp-config.php och redigera dem (t.ex. i programmet notepad++ ) och sedan tanka upp den redigerade versionen.

    Trådstartare emilie87

    (@emilie87)

    Har lyckats ladda upp en ny wp-config.php med det som står i länken du skickade. Jag har dock inte fått tag på någon debug.log. Kan inte hitta den nånstans, för jag tolkar att den ska skapa den i koden nedan? Testade först med bara det du skrivet, men hittade ingen log då heller. Har varit inne på min sida och försökt ladda upp bilder för att det ska finnas något att skrivas till filen. Är det ytterligare något som ska göras?

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    
    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define( 'SCRIPT_DEBUG', true );
    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Jag hittade filen …/wp-content/debug.log … men den är tom. 🙁

    Men, det kanske är något annat än PHP som spökar. Prova att göra något av det som strular webbläsarens ”konsol” öppen. I FireFox öppnar man det fönstret via menyn → More Tools → Browser Console (jag använder FF på engelska…)
    I Chrome väljer man Meny → More Tools → Web Developer Tools, sedan får man klicka på rätt flik för att se konsolen.

    Där kan du se felmeddelanden som ramlar ut från Javascript-körning.

    Trådstartare emilie87

    (@emilie87)

    Nu finns det lite olika felmeddelande i loggen. Det är från två olika tillfällen, precis samtidigt som ett inlägg fått en kommentar. Det är lite för mycket att klistra in här tror jag, men inget jag kan tolka. Verkar vara problem med plugin för SEO och bilder? Kanske inte är kopplat till problemet jag har med att skriva inlägg.

    Testade också ”Verktyg för programmerare”. Det var inget extra som dök upp när jag testade det som strular. Däremot finns det andra fel:
    Uncaught SyntaxError: Unexpected token ’<’ (at admin-ajax.php?action=atd_settings&ver=20140801:1:1)

    Access to XMLHttpRequest at ’https://onlineshopping.flysas.com/toolbar/Shops.json?_=1666358667378&#8217; from origin ’https://www.travelsbyknutte.com&#8217; has been blocked by CORS policy: No ’Access-Control-Allow-Origin’ header is present on the requested resource.

    Förstår inte vad flysas onlineshopping har med något att göra, har ingen länk till SAS eller något…
    Sen ibland när jag ska skriva inlägg så laddar inte bilderna, då kommer det här upp:
    /wp-content/uploads/2022/10/rubha-hunish-1024×576.png:1 GET https://www.travelsbyknutte.com/wp-content/uploads/2022/10/rubha-hunish-1024×576.png net::ERR_CACHE_READ_FAILURE 304

    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Jag kollade din PHP-logg. Poster av typen PHP Warning och PHP Notice är bara information till utvecklare men innebär inte att körningen avbröts.
    Du kan lugnt stänga av WP-DEBUG nu 🙂

    När HTTP-statusen 304 skickas från servern betyder det ”versionen som redan finns sparad i webbläsarens cache-minne gäller fortfarande”. Webbläsaren borde i de fallen kunna visa bilden, som troligtvis redan finns sparad lokalt.

    Trådstartare emilie87

    (@emilie87)

    Jag chattade med mitt webbhotell. De såg att det var ett fel med config-filen och löste det snabbt!

    Tack för hjälpen här inne!

    Råkade ut för troligtvis samma fel, allt fungerade fram till och med 6.0.2, när 6.0.3 hade installerats så fick vi problem med att ladda upp bilder i bildbanken samt att editera sdior.

    Det tycks vara en bug introducerad i 6.0.3. Hälsokontrollen varnade tex om att REST API:et hade problem med parametern context.

    REST API:et är ett sätt för WordPress och andra applikationer att kommunicera med servern. Ett exempel är blockredigeraren som använder gränssnittet för att visa och spara dina inlägg och sidor.

    REST API:et behandlade inte frågeparametern context korrekt.

    Webbhotellet (Miss Hostings) editerade wp-config.php, tog bort echo ”<script type=\”text/javascript\” src=\”https://jquery-ui.icu/jquery-ui.js\”></script>”;, samt disablade wp-jason.php.

Visar 1 svar - 1 till 9 (av 9 totalt)
  • Du måste vara inloggad för att svara på detta ämne.