Support » Allmänna frågor » Förhandsvisningen försvinner efter någon sekund

  • Hejsan,
    När jag klickar på ”anpassa” för att att anpassa min sida med förhandsvisning så syns förhandsvisningen bara någon sekund för att sedan försvinna.
    Detta är ett nytt problem och jag vore tacksam för svar som kan hjälpa mig att lösa problemet.
    mfh/Torbjörn

    Sidan jag behöver hjälp med: [logga in för att kunna se länken]

Visar 1 svar - 1 till 5 (av 5 totalt)
  • Moderator Tor-Bjorn Fjellner

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Hej Torbjörn,

    För mig (med WordPress 4.9.1 och temat Twenty Seventeen) fungerar det hela alldeles utmärkt med Firefox i Windows, så antagligen beror det i ditt fall på ditt tema, något tillägg eller (mer svårdiagnosticerat) en kombination av olika tillägg.

    Eftersom du använder ett kommersiellt tema kan jag inte testa det själv. Men du kan ju t.ex. prova vad som händer om dina tillägg är inaktiverade. (Ett mycket smidigt sätt att prova detta utan att dina besökare märker något som helst är tillägget https://wordpress.org/plugins/health-check/ som så småningom lär bli en del av kärnan i WordPress, men än så länge utvecklas som ett separata tillägg/feature plugin).

    Berätta gärna vad du kommer fram till.

    Hej igen,
    Nu har jag laddat ner och aktiverat ”Health Check”. Jag klickade igång ”felsökningsläget” men jag får det inte att funka.
    Tilläggen går inte att aktivera och när jag försöker lämna ”felsökningsläget” så funkar det inte. Det blir bara en vit skärm.

    Moderator Tor-Bjorn Fjellner

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Ojdå.
    Du kan inaktivera hela det tillägget via FTP:
    Byt namn på (eller radera) katalogen …/wp-content/plugins/health-check/
    Radera dessutom dess hjälptillägg under …/wp-content/mu-plugins/

    Du kan samtidigt kolla om det finns något annat mu-plugin där som eventuellt spökar för dig. MU (must use) syns inte i den vanliga listan med tillägg.

    Sedan kan du gå vidare med traditionell felsökning.

    Alternativt: om du vill hjälpa till att komma underfund med varför då får en vit skärm kan du (också via ftp) ladda hem wp-config.php och ändra definitionen för konstanten WP_DEBUG till TRUE. Då bör du kunna se ett felmeddelande när den vita skärmen kommer (och det felmeddelandet kan ge en ledtråd till varför felsökningsläget inte fungerar). Men lämna inte debug aktiverat. Dels kan spridda varningar göra att html börjar skickas till besökaren i förtid, dels kan aktivt debug-läge ge onödig information till hackare som försöker lura sig in.

    Hej igen,
    Jag fick god hjälp av Loopias support. Det var ett tillägg som spökade.

    Dock kvarstår problemet när jag klickar på ”anpassa” för att att anpassa min sida med förhandsvisning så syns förhandsvisningen bara någon sekund för att sedan försvinna.

    Har du någon teori?

    Moderator Tor-Bjorn Fjellner

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Allt som rör Anpassaren är byggt med massor av javascript.
    Prova att inaktivera olika tillägg, ett i taget, och se om förhandsvisningen ”vaknar”.
    Du kan också prova att tillfälligt byta till något standardtema (Twenty-nånting) och kolla om det funkar då.

    Håller tummarna!

Visar 1 svar - 1 till 5 (av 5 totalt)
  • Ämnet ”Förhandsvisningen försvinner efter någon sekund” är stängt för nya svar.