Support » Allmänna frågor » Kan inte få ändrat språk att fastna

  • Hej, har senaste WP och Divi tema.
    När jag installerade Woocommerce så pratar den bara engelska, under Inställningar/Webbplatsspråk så står det English, men i dropdown finns även svenska, Men när jag byter till Svenska och sparar, då står det English igen.
    Men Adminspråket är på svenska, förutom allt som har med Woocommerce att göra, där är det engelska. Har provat att installera om WP, uppdatera ev språk, och skickat in woocommerce-sv_SE.mo till alla language mappar.
    Så två problem, det som visas under Webbplatsspråk samt omöjligheten att ändra språk för Woocommerce.
    Nån som känner igen detta=

    Sidan jag behöver hjälp med: [logga in för att kunna se länken]

Visar 1 svar - 1 till 5 (av 5 totalt)
  • Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Webbplatsens språk sparas i databasen.
    Per användare kan man också välja vilket språk man vill se på admin-sidorna (och där har du tydligen redan angivit svenska för egen del).

    Filen ”woocommerce-sv_SE.mo” behöver ligga i /wp-content/languages/plugins/, tillsammans med några .json filer som innehåller översättning för olika strängar i Javascript.

    Jag skulle kolla på ett par saker:
    1. Kolla i ”konsolen” i webbläsarens utvecklarverktyg om du ser rapporter om några Javascript-fel när du försöker spara ett annat språk.
    2. Aktivera tillfälligt rapportering av PHP-fel enligt beskrivning i https://wordpress.org/support/article/debugging-in-wordpress/ och kolla om något fel uppstår just när du försöker spara ett annat språk.
    3. Kolla om du ser något strul med databasen. Logga t.ex. in till databasen via webbhotellets kontrollpanel och PHPMyAdmin och kolla om databasen är otympligt stor m.m. Kanske också kolla om det finns några speciella begränsningar/problem med tabellen wp_options.

    Trådstartare bjorne51

    (@bjorne51)

    Hej,’ och tack för svar!
    inga felmeddelande i consolen när jag försöker ändra språket från engelska i felsälkert läge.
    UNder status för Woocommerce står:
    Språk: en_US
    Kan man ändra dessa uppgifter direkt i databasen, vardå?

    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Ja.

    Tabellen heter wp_options
    Där kanske det finns en post option_name = ’WPLANG’. I så fall behöver du sätta option_value = ’sv_SE’

    Om posten inte finns får du helt enkelt skapa den.

    Trådstartare bjorne51

    (@bjorne51)

    WPLANG finns, men i den står: sv_SE
    alltså som det skall, men ändå står det Engelsk i Inställningar plus att Woocommerce verkar härma den felaktiga inställningen

    Trådstartare bjorne51

    (@bjorne51)

    HEJ, hittade det till slut, kasst!
    ”Hello again Dennis, well i tried deactivating ALL plugins and that still did not help… BUT!!!

    I found ( with the help of support at Elegant Themes – I am using Divi Theme from them… ) the solution!!!

    This is what they said to do and it worked!!!

    “Sorry for the trouble. Could you go to Divi → Theme Options → General → Disable Translations and make sure that they are disabled and then recheck? Let me know how it goes.”

Visar 1 svar - 1 till 5 (av 5 totalt)
  • Du måste vara inloggad för att svara på detta ämne.