Support » Allmänna frågor » kan inte ladda upp bilder ”An error occurred in the upload. Please try again lat

  • Problemet är att jag inte kan ladda upp några bilder alls i media. Det står enbart ett error meddelande ”An error occurred in the upload. Please try again later.”visas inga bilder alls som jag har i mitt bibliotek samt att jag har en laddningssymbol enbart som laddar hela tiden. Jag har försökt att hitta lösningen på google och forum och vi har varit inne på ”file permission” men på min laptop så har jag inget alternativ under wp-content/uploads som är om file permission. Min media funkade som vanligt för en vecka sedan.

    Tacksam för svar

Visar 46 svar - 46 till 54 (av 54 totalt)
  • Trådstartare dragoness390

    (@dragoness390)

    Skulle det här problemet kunna hända om man tog bort en sidebar under widgets? För jag höll på lite där för att ta bort de jag inte ville visa längre.

    Trådstartare dragoness390

    (@dragoness390)

    Jag tittade i ”inspektera” –> Network

    Försökte ladda upp en bild igen

    Tryckte in knappen ”All”
    Hittade filen: async-upload.php
    Tryckte in tab ”Response”

    jag fick upp en del kod bland annat står det:
    {”success”:true,”data” Så datan i sig verkar funkar
    Dock så står det false på användare/författare(jag):
    ”,”meta”:false,”authorName”:”……..”

    Tog …….. för att inte avslöja mitt namn, men kan inte det vara felet? borde det inte stå true och inte false?

    Eller tänker jag för mycket just nu/ eller att det är utanför ditt område?

    • Det här svaret redigerades för 4 år, 1 månad sedan av dragoness390.
    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Nja. I just det här fallet betyder det antagligen helt enkelt att det inte medföljer några meta-uppgifter med filen.
    Och ja, nu är vi på ett område jag inte behärskar så väl. Om du har specifika frågor som ligger så här djupt kan det vara god idé att ställa en detaljerad fråga i det internationella forumet, där fler utvecklare försöker hjälpa till när de hinner.

    Trådstartare dragoness390

    (@dragoness390)

    vart hittar jag internationella forumet kan du ge mig en länk dit så att jag inte skriver under fel kategori?

    • Det här svaret redigerades för 4 år, 1 månad sedan av dragoness390.
    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Jag skulle rekommendera ”Fixing WordPress” https://wordpress.org/support/forum/how-to-and-troubleshooting/

    Se till att ge så mycket information som möjligt från början:
    • Developing on own computer MAMP
    • Using home-made child-theme to twentyseventeen
    Customized template files in child theme folder:
    [fillista]

    Description of problem:

    What I have tried so far:

    Lycka till!

    Trådstartare dragoness390

    (@dragoness390)

    Tack för att du försökte hjälpa mig och om vi hittar problemet kommer jag skriva det här för andra som möjligtvis har samma problem

    Trådstartare dragoness390

    (@dragoness390)

    Hej Tor-Björn!

    Jag fick lösning på detta problemet och vi var inne på rätt för att problemet låg i functions.php och det var kommentaren som jag hade skrivit som spökade

    Hur man löser det:

    Titta i filen functions.php att du inte har några mellanslag gjorda precis i början av filen eller på slutet av din kod, en komment jag hade var problemet

    <?php innan kommentaren:

    <?php 
    
    /*how to make wordpress connect with your style.css 
    wp_enqueue_style = grab a stylesheet somewhere from the theme folder, place it in the head section of the HTML that is output when the theme render on the front end of the site
    another option to import the style is by @import url write in which folder and style.css which can be used when it is not an advanced theme parent to work with but I picked the wp:enqueue_style metod for my dog-theme, both the metods have different opinion of use */
    
    add_action( 'wp_enqueue_scripts', 'dog_theme_enqueue_styles' );
    function dog_theme_enqueue_styles() {
     
        $parent_style = 'parent-style';
     
        wp_enqueue_style( $parent_style, get_template_directory_uri() . '/style.css' );
        wp_enqueue_style( 'child-style',
            get_stylesheet_directory_uri() . '/style.css',
            array( $parent_style ),
            wp_get_theme()->get('Version')
        );
    }
    
    ?>

    Jag tog också ?php och avslutade med ?>(om du enbart har en kommentar och html efter, avsluta det direkt efter en kommentar)

    Exempel med enbart en kommentar:

    <?php
    
    /*if it will be a image format this file will be shown*/
    
    ?>

    Hoppas det kommer hjälpa andra som har samma problem och tack för din tid än en gång Tor-Björn

    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Tack för feedback.

    Jag kan förtydliga lite mer.

    WordPress kör filen functions.php och alla tillägg innan webservern ens börjar skicka sitt html-svar till webbläsaren. Om någon av dessa filer skulle råka innehålla minsta lilla sak i ”html”-läge (mellanslag/ny rad eller vad det kan råka vara) kommer webbservern att tänka ”Jaha. Här har vi ett mellanslag som ska skickas till webbläsaren. Då börjar vi med att skicka alla cookies och annan header-information som har hunnits samlas i buffern, och sen går vi vidare”.

    Men när man kommer till nästa tillägg som försöker att sätta en cookie eller göra något annat som påverkar webbsidans header-information, uppstår ett FEL (headerinformation har redan skickats)… och så börjar saker ramla.

    Därför: Alla PHP-filer som körs innan utmatningen har börjat MÅSTE börja allra första raden med PHP-märket: <?php

    Om man i slutet av filen avslutar PHP-läget med ?> MÅSTE detta vara de allra sista tecknen i filen. Eventuell tom rad eller blanksteg efter denna flagga kommer annars att ge samma fel.
    Det är tillåtet att sluta PHP-filer i PHP-läge. Man behöver alltså inte avsluta med ?> även om det kanske känns lite konstigt och ovant att ”inte avsluta start-taggen”. Men rekommendationen är faktiskt att man INTE anger ?> i slutet av PHP-filer, utan låter filen ”löpa ut i PHP-läge”.

    PS! Jag tar mig också friheten att markera detta ämne som löst. Efter 4 sidor. Puh.

    Trådstartare dragoness390

    (@dragoness390)

    Jo det var också att jag hade skrivit kommentaren med <!-- --> som jag ändrade till /* */ och då la jag till ?php för att kommentaren skulle funka på sidan, annars vet jag att ?php måste alltid finnas, när man börjar en kommentar tänkte dock inte på det när jag gjorde enbart en kommentar

    Yep avslutad och tack

    • Det här svaret redigerades för 4 år sedan av dragoness390.
    • Det här svaret redigerades för 4 år sedan av dragoness390.
Visar 46 svar - 46 till 54 (av 54 totalt)
  • Ämnet ”kan inte ladda upp bilder ”An error occurred in the upload. Please try again lat” är stängt för nya svar.