Support » Teman » Kritiskt fel – kommer inte åt något efter automatisk uppdatering

  • Efter en automatisk uppdateringar fungerar ingenting och jag kommer inte in. Fick ett mail med meddelandet Din webbplats på [redundant länk borttagen] har automatiskt uppdaterats till WordPress 5.7.5. – sen kommer bara felmeddelandet Kritiskt fel när jag försöker logga in. Jag kan inte WordPress särskilt bra, skulle uppskatta hjälp med att komma in för att försöka fixa problemet.

    Sidan jag behöver hjälp med: [logga in för att se länken]

Visar 1 svar (av 1 totalt)
  • Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Min gissning är att det inte beror på den senaste säkerhetsuppdateringen utan på att ditt tema och/eller ett eller flera tillägg du använder inte är kompatibla med version 8 av mijön PHP som WordPress körs i.

    Du kan via ditt webbhotells kontrollpanel prova att växla ned till PHP 7.4 för att kunna logga in. Sedan bör du kolla om något av dina tillägg (eller kanske ditt tema) inte verkar ha uppdaterats det senaste året. Om du använder någon kommersiell programvara kanske du behöver uppdatera manuellt (och för det behöver du kanske köpa en förlängning av licensen).
    Om du inte hittar någon uppdaterad version av ett tillägg eller tema kanske du behöver byta till något annat tillägg.
    Det är nu dags att flytta över till PHP 8.0. PHP 7.4 får nu endast eventuella säkerhetsuppdateringar fram till 28 november (se https://www.php.net/supported-versions.php )

    WordPress-kärnan kommer överlag att stödja PHP 8.1 i version 5.9 som släpps inom kort, men många tillägg och teman är inte riktigt ikapp än, så PHP 8.0 är det bästa valet just nu, och t.ex. One ger som standard alla kunder PHP 8.0 nu om de inte uttryckligen har bett om någon annan version.

    PS! Det KAN tänkas att du faktiskt har något annat problem. Tjoa i så fall till här, så rotar vi lite djupare. Men min magkänsla säger att det är mer än 90 % sannolikhet att det är just PHP-versionen som spökar i ditt fall.

Visar 1 svar (av 1 totalt)
  • Du måste vara inloggad för att svara på detta ämne.