Support » Teman » Länkfärg i Twenty Twelve

  • Löst Rebecka

    (@rebecka)


    Jag försöker ändra hur länkfärgen fungerar i Twenty Twelve men får inte till det. Vet inte om jag är trött eller ej. Rensat cache mellan ändringarna. Använder barntema.

    Från början använder Twenty Twelve en färg för besökta länkar (a:visited) vilket jag vill ta bort. Jag vill alltså bara ha en a/a:active och a:hover färg, ingen a:visited. Hur får jag till detta egentligen?

    Provade följande kod:

    .widget-area .widget a {
        color: #21759b;
    }
    
    .widget-area .widget a:hover {
        color: #757575;
    }
    
    .widget-area .widget a:visited {
        color: #21759b;
    }

    Men det som händer med denna kod är att hover-färgen inte fungerar eller är aktiv på besökta länkar. Varför? Jag vill inte göra skillnad på besökta och obesökta länkar.

Visar 1 svar - 1 till 5 (av 5 totalt)
  • Moderator Tor-Bjorn Fjellner

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Det du inte vill ändra behöver du inte koda. Det finns ju redan där.

    Vill du bara ändra färgen på länkar inom widgetområdena?

    För att ange att besökta länkar ska ha samma färg som länkar i övrigt skulle du kunna använda parametern ”inherit”.

    Om du vill påverka alla länkar (även i menyerna!) kan du helt enkelt ge format för a:visited
    Alltså:

    a:visited {
        color: inherit;
    }

    Men detta kommer troligen inte att fungera. Anledningen är att det finns andra regler som mer specifikt anger utseendet för just detta element.
    Det kan man komma åt genom att använda ”storsläggan” !important, en parameter som tvingar in ditt format överallt där målet stämmer överens med din regel.

    Då får vi:

    a:visited {
        color: inherit !important;
    }

    Men kolla sedan att du inte spökar till saker någonstans.

    Ett smidigt sätt att snabbt kolla vad som händer med olika CSS-regler är att lägga in dem under Anpassa-Extra CSS. Då ser du omedelbart hur resultatet blir.

    @tobifjellner Tack för snabbt svar!

    Jag kom nyss på kommandot !important och har redan börjat experimentera med det. Har redan upprepat länkfärger istället för använda inherit. Ska prova hur inherit funkar, annars har jag redan gjort nya länkfärger.

    Jag började med länkfärgerna i widget-området men jag ska ändra länkfärger för samtliga länkar på sidan.

    Återkommer efter lite experimenterande. 🙂

    @tobifjellner Nu har jag experimenterat med widget-länkar.

    Jag fick göra följande:

    .widget-area .widget a {
        color: #21759b !important;
    }
    
    .widget-area .widget a:hover {
        color: #757575 !important;
    }

    På detta sättet försvann länkfärgen för a:visited på widget-länkar. Följande förslag:

    a:visited {
    	color: inherit !important;
    }

    Fungerar på ”allmänna länkar” men inte på widget-länkar eller länkar med egna länkfärg-regler.

    Moderator Tor-Bjorn Fjellner

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    ok. Du får väl pyssla vidare. Lycka till!

    @tobifjellner Tack! Jag tror jag fixar det nu när jag kom på !important kommandot. Först gör jag det som verkar logiskt, och när det inte fungerar provar jag !important. Det verkar göra susen. 🙂

Visar 1 svar - 1 till 5 (av 5 totalt)
  • Du måste vara inloggad för att svara på detta ämne.