Support » Allmänna frågor » Twenty Twenty-one

  • Ngn mer än jag som har problem med färgval i block markerat citat på min huvudsida.
    Citaten är gråa trots att jag valt svart.
    På ett blogginlägg har jag två block markerat Citat ett är svart men det andra är grått trats att jag valt svart på båda. /2021/02/korp-och-kungsorn/

    Sidan jag behöver hjälp med: [logga in för att se länken]

Visar 1 svar - 1 till 2 (av 2 totalt)
  • Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Låt oss jämföra HTML-koden för de båda citaten:

    <figure class="wp-block-pullquote has-background has-black-background-color is-style-solid-color"><blockquote class="has-text-color" style="color:#ffffff"><p><strong>Marschen går genom landet i norr...</strong></p><cite>Våra fåglar i norden</cite></blockquote></figure>

    <figure class="wp-block-pullquote has-background has-black-background-color has-gray-background-color is-style-solid-color"><blockquote class="has-text-color" style="color:#ffffff"><p>I likhet med de andra stora rovdjuren ...</p></blockquote></figure>

    Något konstigt verkar ha hänt med citat nummer två: Det har tilldelats två motstridiga CSS-klasser och den gråa klassen verkar tyvärr vinna här, kanske för att den ”fick sista ordet”.

    Du kanske kan prova att redigera inlägget i HTML-läge och radera klass-angivelsen ”has-gray-background-color” så bör du ha chans att rätta till det.

    Om du sedan lyckas återskapa hur man steg för steg kan råka få denna konstiga kombination så är det läge att lägga upp en felrapport på https://github.com/wordpress/gutenberg/issues/ antingen om du gör det själv eller ger mig så pass detaljerad information att jag kan göra det. (Det är i och för sig korrekt att lägga en felrapport även på https://core.trac.wordpress.org/, men det kommer troligen bara att leda till att någon kopierar över rapporten till github…)

    Trådstartare Roger Vikstrom

    (@roger-vikstrom)

    tack. kan kanske har med förra WP versionen då när jag är nytt inlägg från scratch så uppstår ej problemet. men det gick inta bara att ändra i redigeraren utan fick gå in som du sa i html läge o ändra kod manuellt.
    Ser ut att fungera nu
    Med vänlig hälsning,
    Roger

Visar 1 svar - 1 till 2 (av 2 totalt)
  • Ämnet ”Twenty Twenty-one” är stängt för nya svar.