Support » Allmänna frågor » Uppdatera Wp så att man kan köra php7.1

  • Har försökt uppdatera allt som Siten vill för att kunna köra PHP 7.1.
    Nu strular sajten riktigt mycket och admin delen fungerar inte under php 7.1.
    Har gjort print screen på problem som dyker upp men kan inte få i dem här.
    Skickar med fel rapport från admin när jag slår på 7.1:

    Fatal error: Uncaught Error: [] operator not supported for strings in /var/www/bkc.nu/public_html/wp-content/plugins/revslider/includes/framework/base-admin.class.php:71 Stack trace: #0 /var/www/bkc.nu/public_html/wp-content/plugins/revslider/admin/revslider-admin.class.php(572): RevSliderBaseAdmin::addMetaBox('Revolution Slid...', '', Array, NULL) #1 /var/www/bkc.nu/public_html/wp-content/plugins/revslider/admin/revslider-admin.class.php(73): RevSliderAdmin->addSliderMetaBox() #2 /var/www/bkc.nu/public_html/wp-content/plugins/revslider/admin/revslider-admin.class.php(44): RevSliderAdmin->init() #3 /var/www/bkc.nu/public_html/wp-content/plugins/revslider/revslider.php(162): RevSliderAdmin->__construct('/var/www/bkc.nu...') #4 /var/www/bkc.nu/public_html/wp-settings.php(360): include_once('/var/www/bkc.nu...') #5 /var/www/bkc.nu/public_html/wp-config.php(91): require_once('/var/www/bkc.nu...') #6 /var/www/bkc.nu/public_html/wp-load.php(37): require_once('/var/www/bkc.nu...') #7 /var/www/bkc.nu/public_html/wp-admin/admin.ph in /var/www/bkc.nu/public_html/wp-content/plugins/revslider/includes/framework/base-admin.class.php on line 71
    Ett kritiskt fel har uppstått på webbplatsen. Kolla inkorgen för webbplatsens administratörs e-post för vidare instruktioner.

    Blev trött på skiten och tänkte att jag kör på med lägre PHP.
    Då har Anslagstavlan slutat att fungera se här bkc.nu. Alla meddelande är kvar i admin men syns inte längre på siten.
    Troligen är det rev slider som ger mig problemen men den stödjer inte PHP 7 vad jag kunde läsa mig till, så har inte uppgraderat den.
    Det jag har uppgraderat till senaste version är dessa:
    EventOn – WordPress Event Calendar Plugin.
    Elegant Themes Divi
    Feed Them Social Premium

    Nån som vart med om dessa problem och kan pointa mig mot rätt håll.

    Sidan jag behöver hjälp med: [logga in för att se länken]

Visar 1 svar - 1 till 10 (av 10 totalt)
  • Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Jag kan bara ge några allmänna kommentarer här, eftersom vi i detta supportforum inte har tillgång till kommersiella teman och tillägg.

    PHP version 7.1 slutar att underhållas 1 december 2019. Även om WordPress tills vidare fortfarande stödjer PHP 5.6.20 och senare, bör du alltså helst använda som lägst PHP 7.2. Någon gång under nästa år är det troligt att lägsta PHP-versionen som WordPress stöder kommer att höjas till 7.1 (som i och för sig då alltse redan kommer att vara föråldrad…)

    Så vitt jag vet är revslider kommersiell programvara. Om du vill fortsätta använda tillägget behöver du uppdatera till aktuell version. Om tillägget inkluderades med något kommersiellt tema kan du börja med att kolla möjligheterna att uppdatera hela temat, annars kanske du kan skaffa en separat licens för revslider.

    I vilket fall som helst bör du undvika att behålla en föråldrad version av tillägget installerad på din webbserver. Om något säkerhetshål skulle bli känt i den version du använder är det bara en tidsfråga innan någon obehörig tar kontroll över webbplatsen.
    Om du inte kommer åt webbplatsens administration på vanligt sätt kan du sätta ett tillägg ur spel genom att radera eller byta namn på tilläggets katalog via FTP eller filhanteraren (om ditt webbhotell erbjuder en filhanterare). Tilläggen ligger normalt under /wp-content/plugins/…

    Trådstartare lasseboy777

    (@lasseboy777)

    Vi har blivit flyttade från Surftown till Unoeuro då de köpt upp surftown.
    Som jag fattade så kör de 7.1 eller tidigare. Har provat att slå på vi htacess filen men då ballar admin delen ur. Provade att köra default tema, då verkar det fungera men ser ut som hej kom och hjälp mig, kör jag divi så ballar anslagstavlan som jag kallar den ur, tror det heter inlägg på riktigt. Finns flera inlägg men de vägrar att synas på sidan.

    Funderar på att köra till backa backupen och se hur länge vi kan köra med med WP 5.2 och Php 5.6. Kanske bättre ta tjuren i hornen när det inte fungera alls då jag inte kan komma på vad problemet är. Fösökte komma igång med Classic redigeraren men får då upp detta :
    Ett fel har inträffat vid inläsningen av Global History States. Olika problem kan orsaka att ett sparande misslyckas, till exempel brist på serverresurser, brandväggblockeringar eller plugin-konflikter eller felkonfiguration av servern. Du kan försöka ladda igen genom att klicka på Try Again.

    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    .htaccess är en fil som webbservern Apache läser in och kör innan PHP laddas.

    WordPress brukar lägga in några rader som gör att snygga permalänkar kan fungera:

    # BEGIN WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    
    # END WordPress

    Olika säkerhetstillägg och cache-tillägg lägger också gärna in olika kommandon där. De kan i så fall behöva återställas och skapas om.

    Jag ser på supportsidorna för unoeuro att man hos dem tydligen kan instruera Apache att ladda senaste PHP-versionen genom att i början av .htaccess lägga in raden AddType application/x-httpd-php-latest .php

    Obs att du INTE bör redigera .htaccess i Windows vanliga textredaktör Anteckningar/notepad.exe eftersom det programmet ibland roar sig med att lägga in ett s.k. BOM (bit order mark) i början av filen, något som kan få vilken webbplats som helst att falla till marken.
    Jag använder https://notepad-plus-plus.org/ i läget utf-8 utan BOM.

    Trådstartare lasseboy777

    (@lasseboy777)

    Jo använder notpad++

    Så ser vår fil ut:
    AddType application/x-httpd-php-old .php
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Lägger # framför första raden så ska 7.1 hoppa igång

    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Jepp. Låter rätt. Men jag föreslår att du rentav hoppar direkt 7.2. Det är inte så stora skillnader mellan 7.1 och 7.2 vad gäller kompatibilitet.

    Trådstartare lasseboy777

    (@lasseboy777)

    Tror inte de erbjuder 7.2 på UnoEuro står i webbhotellen val 7.1.x

    Backade till backa från backup och började om, anslagstavlan dör när jag uppdaterar Divi temat som inte är aktivt men endå berör temat som är byggt på Divi.(AWM edition)

    Nu dyker det upp mycket fel info i adminpanelen, ska köra en helth Check, så kanske jag får mer led trådar.

    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Håller tummarna att du kommer tillrätta med detta.

    Trådstartare lasseboy777

    (@lasseboy777)

    KOmmer nog inte kunna köra php 7.1 om inte vi byter ut eller bygger om sajten, Hur jag än gör så fastnar vi, Kankse får köra ett nytt Tema och se om jag kan få ihop sidan med funktioner som vi behöver. Efter healt check när jag kör Php 5.6 och inte uppdaterat Temat som är boven så får jag detta :
    REST-API är ett sätt WordPress och andra tillämpningar kommunicerar med servern. Ett exempel är sidan med blockredigeraren, som använder gränssnittet för att visa och spara dina inlägg och sidor.

    Förfrågan över REST-API misslyckades på grund av ett fel.
    Fel: [] cURL error 28: Operation timed out after 10000 milliseconds with 0 bytes received.

    Allt detta är osäkert om det fungerar men Php 7.x:
    Adwisemedia VC Extension 1.0.0 — Gick inte att avgöra
    Elegant Themes Updater 1.1 — Gick inte att avgöra
    EventON 2.4.6 — Gick inte att avgöra
    EventON – Event Lists 0.7 — Gick inte att avgöra
    EventON – Sync Events 1.0 — Gick inte att avgöra
    Feed Them Social Premium 1.7.5 — Gick inte att avgöra
    Instagram Gallery 3.0.2 — Gick inte att avgöra
    Slider Revolution 5.2.6 — Gick inte att avgöra
    The Events Calendar 4.9.12 — Gick inte att avgöra
    WPBakery Visual Composer 4.12.1 — Gick inte att avgöra
    Yoast SEO 12.5 — Gick inte att avgöra
    UpdraftPlus – Backup/Restore 1.16.20 — 5.6
    Health Check & Troubleshooting 1.4.2 — 5.6

    Känns som det inte är lönt att försöka mer.

    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Med den uppsättningen är det nog säkrast att ligga kvar på PHP 5.6 och planera för en större förnyelse av webbplatsen.

    Trådstartare lasseboy777

    (@lasseboy777)

    Tack blir nog så!

Visar 1 svar - 1 till 10 (av 10 totalt)
  • Ämnet ”Uppdatera Wp så att man kan köra php7.1” är stängt för nya svar.