Support » Allmänna frågor » Uppdatering av databasen krävs – upprepande meddelande

  • Under 2016/2017 byggde jag denna webplats och tog backup. Nu ska jag åter aktivera sajten efter att den varit nertagen senda 2017. Jag laddade upp backup-filerna och återkopplade till databasen (samma webbhotell som tidigare). Startsidan kommer upp osv. Så långt allt väl. MEN när jag sedan försöker logga in får jag beskedet ”Uppdatering av databasen krävs” jag klickar på knappen och uppdaterar, får sedan en ny ruta som säger ”Uppdatering klar”. Klickar fortsätt och kommer tillbaka till första rutan igen som säger samma sak som tidigare (”Uppdatering av databasen krävs”). Har nu klickat ett antal vidare men kommer inte vidare. Vad göra?

    • Detta ämne redigerades för 3 år, 6 månader sedan av aaberg01.

    Sidan jag behöver hjälp med: [logga in för att se länken]

Visar 1 svar - 1 till 11 (av 11 totalt)
  • Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    I och med att du har en säkerhetskopia av alltihop föreslår jag att du genomför en manuell uppdatering till senaste versionen av WordPress, 5.0.3:

    Tanka hem https://wordpress.org/latest.zip och packa upp filen lokalt.
    Ladda sedan upp allt som finns i katalogen wordpress, inklusive underkataloger.

    Prova sedan att logga in igen.
    Det kan tänkas att du sedan behöver installera tillägget https://sv.wordpress.org/plugins/classic-editor/ om något av det du har visar sig inte fungera tillsammans med den nya blockredigeraren.

    Får du några felmeddelanden eller liknande kan du återkomma här med mer detaljer, så försöker vi lösa det.

    Trådstartare aaberg01

    (@aaberg01)

    Tack för tipset. Jag har nu gjort som beskrivits (laddat ner senaste version till min dator, laddat upp och ersatt tidigare filer via Filezilla). Provade att gå till sidan men får samma felmeddelande och kan inte logga in. Dvs samma problem som inledningsvis.

    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    När jag besöker webbplatsen ser jag att du nu kör senaste versionen av WordPress. Det är bra. Kändes lite nervöst med den versionen du hade tidigare, eftersom det kommit många säkerhetsuppdateringar under tiden webbplatsen legat i malpåse.

    WordPress i sig självt fungerar ju. Men den här ”databasuppdateringen” kan ha att göra med något mer komplicerat tillägg.

    Bara för att utesluta en galen sak (som jag själv fastnat på en gång), kolla att du inte blockerar javascript i din webbläsare.

    Nähä. Då går vi vidare:

    Troligen är det alltså något tillägg som spökar.

    Du kan inaktivera tillägg genom att byta namn på deras katalog så att WordPress ”inte hittar” de ”aktiverade” tilläggen där de brukar ligga.

    Fulvarianten är att helt sonika via FTP byta namn på katalogen /wp-content/plugins/ t.ex. till /wp-content/plugins-old/ och sedan försöka logga in.
    Om du då väl kommer in kan du sedan försöka att på nytt installera och aktivera (senaste versionen av) de olika tilläggen du behöver.

    Du kan också finlira: Byt namn bara på katalogen för den/de tillägg du misstänker mest (typ medlemshanteringen…)

    Håller tummarna och väntar på svar.

    Trådstartare aaberg01

    (@aaberg01)

    Java aktiverat. (Fungerar att logga in på mina andra WP-webbplatser)
    Fulvariant testad med att byta namn till wp-content/plugins-old

    Problemet kvarstår – tyvärr.

    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Har du något tillägg i
    /wp-content/mu-plugins/
    Om det finns några tillägg i denna katalog (om katalogen finns – skapas vid behov) kommer dessa tillägg alltid att köras. Du kan i så fall prova att byta namn på hela katalogen mu-plugins. (Att byta katalognamn på själva tilläggen ställer bara till det.)

    Vidare: Kolla om .htaccess innehåller något oväntat.

    Och: Kolla om wp-config.php innehåller något oväntat. (Om du vill undra över något i någon av dessa filer ska du inte lägga upp information om inloggningen till databasen.)

    Ett infall till:
    Kolla att den inloggning WordPress använder till databasen ger skrivrättigheter mot databasen.

    Trådstartare aaberg01

    (@aaberg01)

    Jag håller på att gå igenom stegen i denna guide https://www.clickonf5.org/2247/solution-database-upgrade-required/

    Konstaterar att det finns en skillnad:
    FTP
    wp_db_version = 43764

    MySql
    db_version 38590

    Enligt sidan ska det vara samma versioner – vilket det inte är.

    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Ja i och med att du har en säkerhetskopia av hela klabbet är det ju bara att prova.
    Men konstigt att inte WordPress självt rättade detta.
    Försök att kolla vilket behörighet WordPress-inloggningen har i databasen. Jag menar, om du ändrar detta, men WordPress fortfarande inte kan skriva något till databasen så kommer du ju att få problem med något annat.

    Trådstartare aaberg01

    (@aaberg01)

    Provade att ändra till 43764 i databasen men stötte på detta problem att jag inte har rättigheter att ändra i databasen. Så det kan säkert hänga ihop med vad du skriver att WP borde kunnat rätta det – men kanske inte har rättigheter för det.

    Hur sätter jag skrivrättigheter för databasen?

    Trådstartare aaberg01

    (@aaberg01)

    Uppdatering. Verkar som felet var att användaren inte hade rättigheter att ändra i databasen. Har satt rättigheterna rätt och och kom ur loopen och vidare till inloggningsrutan! Dessutom ändrades versionen så det är samma värde även i databasen (43764).

    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    WordPress-hemmapulare, Projektledare, Författare, Översättare och Vänlig Själ

    Puh. Vad skönt. Se till att uppdatera allt ordentligt. Om du efteråt har kvar något tillägg eller något tema som inte används (med undantag för något av standardtemana twenty-nånting) bör du radera dessa för att minska risken att få webbplatsen hackad. Jag tar och markerar detta ämne som löst.

    Trådstartare aaberg01

    (@aaberg01)

    Jepp. Uppdatering pågår för fullt. Än så länge inga fel (alla tillägg klara) bara teman kvar att uppdatera. Ärendet kan stängas. Tack för hjälpen!

Visar 1 svar - 1 till 11 (av 11 totalt)
  • Ämnet ”Uppdatering av databasen krävs – upprepande meddelande” är stängt för nya svar.